Today i was installing laravel 10 with php version 8.2 and i encountered an issue
laravel/framework[v10.0.0, ..., v10.3.2] require composer-runtime-api ^2.2 -> found composer-runtime-api[2.1.0] but it does not match the constraint.
This issue occurred due to old composer. So we can quickly fix this by running below command
composer clearcache composer selfupdate
May be you can error for the permission as below
[Composer\Downloader\FilesystemException] Filesystem exception: Composer update failed: "/usr/local/bin/composer" could not be written. rename(/Users/divya/Library/Caches/composer/composer-temp.phar,/usr/local/bin/composer): Permission denied
Then you can run with